CVE-2025-31128: rubentd gifplayer · Cross-site Scripting
Affects rubentd gifplayerSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 0.3.7 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.3.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade rubentd gifplayer to 0.3.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| rubentd gifplayer | Affected
| Fixed in
|
AI-suggested
1. Immediate upgrade to gifplayer version 0.3.7 or later to ensure the vulnerability is patched. 2. Conduct a thorough audit of all web applications and websites to identify any usage of gifplayer, including indirect dependencies via package managers or bundled libraries. 3. Implement Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts, mitigating the impact of potential XSS attacks. 4. Employ input validation and output encoding best practices on all user-supplied data, even beyond the gifplayer context, to reduce XSS risks. 5. Use security-focused code review and automated scanning tools to detect similar vulnerabilities in custom or third-party JavaScript components. 6. Monitor web traffic and logs for unusual activity that could indicate exploitation attempts. 7. Educate developers about secure coding practices related to client-side scripting and DOM manipulation. 8. If immediate patching is not feasible, consider temporary mitigations such as disabling the gifplayer plugin or restricting access to affected web pages until the update can be applied.
Description
gifplayer is a customizable jquery plugin to play and stop animated gifs.gifplayer contains a cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 0.3.7.