Skip to main content
CVE-2025-31510VulnerabilityPublished

CVE-2025-31510: LemonLDAP::NG · XSS or 'Cross-site Scripting'

Affects LemonLDAP::NGSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High : upgrade to 2.21.0 or 2.16.5 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.21.0, 2.16.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade LemonLDAP::NG to 2.21.0 or 2.16.5.

Affected software

ProductAffectedFixed in
lemonldap-ngLemonLDAP::NGAffected
  • >=2.0.8 <2.16.5
  • >=2.17.0 <2.21.0
Fixed in
  • 2.21.0
  • 2.16.5
GitHublemonldap-ng/lemonldap-ngpkg:github/lemonldap-ng/lemonldap-ngOther threatsAffected
  • =2.0.8
  • =2.17.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade LemonLDAP::NG to version 2.21.0 or later, where this vulnerability has been addressed. If immediate upgrading is not feasible, organizations should implement strict input validation and output encoding on the 'tab' parameter to neutralize any injected scripts. Web application firewalls (WAFs) can be configured to detect and block suspicious payloads targeting the 'tab' parameter. Additionally, security teams should monitor authentication portal logs for unusual URL parameters or access patterns indicative of exploitation attempts. Employing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Regular security assessments and penetration testing focused on authentication components are recommended to detect similar vulnerabilities. Finally, educating users about phishing and suspicious links can reduce the risk of successful exploitation via social engineering.

Description

In the portal in LemonLDAP::NG before 2.21.0, cross-site scripting (XSS) allows remote attackers to inject arbitrary web script or HTML (into the login page) via the tab parameter, for Choice authentication.

References

Community reviews

Loading reviews…