Skip to main content
CVE-2025-31513VulnerabilityPublished Updated

CVE-2025-31513: n/a

Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 4.1.14.1.5.32 : update affected systems when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.14.1.5.32, 4.1.14.0.48, 4.1.14.0.43 +8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

AI-suggested

European organizations using AlertEnterprise Guardian should immediately verify their current software build version against the vendor's patched build numbers and upgrade to a version equal to or greater than the specified builds (e.g., 4.1.12.2.1.19 or later). It is critical to apply these updates as soon as possible to eliminate the privilege escalation vector. Additionally, organizations should audit access logs and monitor for unusual API calls, particularly those involving the Request Building Access requestSubmit API and the IsAdminApprover parameter. Implement network segmentation and restrict API access to trusted internal networks or VPNs to reduce exposure. Employ strict role-based access controls and multi-factor authentication for administrative accounts to mitigate the impact of any potential compromise. Regularly review and update security policies related to API usage and access control management. Finally, conduct penetration testing and vulnerability assessments focused on AlertEnterprise Guardian deployments to ensure no residual vulnerabilities remain.

Description

An issue was discovered in AlertEnterprise Guardian 4.1.14.2.2.1. One can elevate to administrator privileges via the IsAdminApprover parameter in a Request%20Building%20Access requestSubmit API call. The vendor has stated that the system is protected by updating to a version equal to or greater than one of the following build numbers: 4.1.12.2.1.19, 4.1.12.5.2.36, 4.1.13.0.60, 4.1.13.2.0.3.39, 4.1.13.2.0.3.41, 4.1.13.2.42, 4.1.13.2.25.44, 4.1.14.0.13, 4.1.14.0.43, 4.1.14.0.48, and 4.1.14.1.5.32.

References

Community reviews

Loading reviews…