CVE-2025-32364: freedesktop Poppler · Integer Overflow or Wraparound
Affects freedesktop PopplerSource CVE Database V5
Not known to be exploited · CVSS 4.0 Medium : upgrade to 25.04.0 when convenient.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 25.04.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 5 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Debian debian/poppler package to 25.04.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Debiandebian/popplerpkg:deb/debian/popplerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade Poppler to version 25.04.0 or later as soon as the patch becomes available to address the integer overflow vulnerability. 2. Until patching is possible, implement sandboxing or containerization for applications that process untrusted PDF files to isolate potential crashes and limit impact on critical systems. 3. Employ input validation and filtering mechanisms to detect and block malformed or suspicious PDF files before processing. 4. Monitor application logs and system stability for signs of crashes related to PDF handling to detect potential exploitation attempts. 5. Restrict local access to systems running vulnerable Poppler versions to trusted users only, minimizing the risk of local exploitation. 6. For environments with automated PDF processing, consider fallback mechanisms or redundancy to maintain availability during potential crashes. 7. Educate users and administrators about the risk of opening untrusted PDFs and enforce security policies accordingly.
Description
A floating-point exception in the PSStack::roll function of Poppler before 25.04.0 can cause an application to crash when handling malformed inputs associated with INT_MIN.