Skip to main content
VulnerabilityPublished Updated

CVE-2025-32461: Tiki · Template Injection

Affects TikiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.9 Critical · fixed in 28.3 : patch Tiki as a priority.

Data as of 30 Oct 2026, 00:15 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.19.9
Patch
Available – fixed in 28.3, 27.2, 24.8 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Tiki to 28.3, 27.2, 24.8 or 21.12.

Affected software

ProductAffectedFixed in
Tiki TikiAffected
  • =22
  • =25
  • =28
  • <21.12
  • >=21.12 <24.8
  • >=24.8 <27.2
  • >=27.2 <28.3
Fixed in
  • 21.12
  • 24.8
  • 27.2
  • 28.3

AI-suggested

Upgrading to any of the fixed versions 21.12, 24.8, 27.2, or 28.3 of Tiki fully mitigates this vulnerability. Users should apply these official fixes promptly to prevent exploitation.

Description

CVE-2025-32461 is a critical vulnerability in Tiki before version 28.3 involving improper neutralization of special elements in a template engine. The flaw exists in the wikiplugin_includetpl component, which mishandles input to an eval function, potentially allowing remote code execution. Fixed versions include 21.12, 24.8, 27.2, and 28.3.

Reports on CVE-2025-32461

References

Community reviews

Loading reviews…