Skip to main content
VulnerabilityPublished

CVE-2025-32786: glpi-inventory-plugin · SQL Injection

Affects glpi-inventory-pluginSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.5.1 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
7.0% chance of exploitation in 30 days – higher than 94% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade glpi-project/glpi-inventory-plugin to 1.5.1.

Affected software

ProductAffectedFixed in
GitHubglpi-project/glpi-inventory-pluginpkg:github/glpi-project/glpi-inventory-pluginOther threatsAffected
  • <1.5.1
Fixed in
  • 1.5.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade the GLPI Inventory Plugin to version 1.5.1 or later to remediate the SQL Injection vulnerability. In addition to patching, organizations should implement the following measures: 1) Conduct a thorough audit of database access logs and GLPI plugin usage to detect any anomalous queries or unauthorized access attempts. 2) Employ web application firewalls (WAFs) with SQL Injection detection rules tailored to GLPI plugin traffic to block exploitation attempts. 3) Restrict database user permissions associated with GLPI to the minimum necessary, limiting the potential damage from successful injection. 4) Regularly review and update input validation and sanitization practices in custom GLPI extensions or integrations. 5) Monitor threat intelligence feeds for any emerging exploit code or attack campaigns targeting this vulnerability. 6) Educate IT and security teams about the vulnerability specifics and ensure incident response plans include steps for SQL Injection incidents. These targeted actions will reduce the attack surface and improve detection and response capabilities beyond generic patching advice.

Description

The GLPI Inventory Plugin handles network discovery, inventory, software deployment, and data collection for GLPI agents. Versions 1.5.0 and below are vulnerable to SQL Injection. This issue is fixed in version 1.5.1.

References

Community reviews

Loading reviews…