Skip to main content
VulnerabilityPublished Updated

CVE-2025-34097: ProcessMaker · Unrestricted File Upload

Affects ProcessMakerSource CVE Database V5

0

Mentioned vulnerabilities

Public exploit available (Metasploit) · CVSS 8.6 High : upgrade to 3.5.4 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade processmaker/processmaker to 3.5.4.

Affected software

ProductAffectedFixed in
Packagistprocessmaker/processmakerpkg:composer/processmaker/processmakerOther threatsAffected
  • <3.5.4
Fixed in
  • 3.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict administrative access to trusted users only and monitor for suspicious plugin uploads. Avoid installing untrusted plugins. Follow vendor communications for updates on patches or official mitigations.

Description

An unrestricted file upload vulnerability exists in ProcessMaker versions prior to 3.5.4 due to improper handling of uploaded plugin archives. An attacker with administrative privileges can upload a malicious .tar plugin file containing arbitrary PHP code. Upon installation, the plugin’s install() method is invoked, resulting in execution of attacker-supplied PHP code on the server with the privileges of the web server user. This vulnerability can be chained with CVE-2022-38577 — a privilege escalation flaw in the user profile page — to achieve full remote code execution from a low-privileged account.

References

Community reviews

Loading reviews…