Skip to main content
VulnerabilityPublished Updated

CVE-2025-34104: Piwik (now Matomo) Web Analytics Platform · Unrestricted File Upload

Affects Piwik (now Matomo) Web Analytics PlatformSource CVE Database V5

0

Public exploit available (Metasploit) · CVSS 9.4 Critical : upgrade to 3.0.3 as a priority.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.9% chance of exploitation in 30 days – higher than 79% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    1 Metasploit module

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade matomo/matomo to 3.0.3.

Affected software

ProductAffectedFixed in
Packagistmatomo/matomopkg:composer/matomo/matomoOther threatsAffected
  • <3.0.3
Fixed in
  • 3.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Matomo version 3.0.3 or later, where plugin upload functionality is disabled by default unless explicitly enabled in the configuration file. If upgrading is not immediately possible, ensure that plugin uploads are disabled in the configuration to prevent exploitation.

Description

An authenticated remote code execution vulnerability exists in Piwik (now Matomo) versions prior to 3.0.3 via the plugin upload mechanism. In vulnerable versions, an authenticated user with Superuser privileges can upload and activate a malicious plugin (ZIP archive), leading to arbitrary PHP code execution on the underlying system. Starting with version 3.0.3, plugin upload functionality is disabled by default unless explicitly enabled in the configuration file.

References

Community reviews

Loading reviews…