Skip to main content
VulnerabilityPublished Updated

CVE-2025-34192: Vasion Print Virtual Appliance Host · Use of Unmaintained Third Party Components

Affects Vasion Print Virtual Appliance HostSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical · patch available : patch Vasion Print Virtual Appliance Host as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Vasion Print Virtual Appliance HostAffected
  • =0
Fixed in–

AI-suggested

A patch is available from the vendor to update the OpenSSL library to a supported version. Since this is a cloud-hosted service, the vendor manages remediation and patch deployment on their side. Users should verify with Vasion that their environment is running a patched version (22.0.893 or later for the Virtual Appliance Host, 20.0.2140 or later for macOS/Linux clients). No additional user action is required if the vendor confirms the environment is up to date.

Description

Vasion Print (formerly PrinterLogic) Virtual Appliance Host versions prior to 22.0.893 and Application versions prior to 20.0.2140 (macOS/Linux client deployments) are built against OpenSSL 1.0.2h-fips (released May 2016), which has been end-of-life since 2019 and is no longer supported by the OpenSSL project. Continued use of this outdated cryptographic library exposes deployments to known vulnerabilities that are no longer patched, weakening the overall security posture. Affected daemons may emit deprecation warnings and rely on cryptographic components with unresolved security flaws, potentially enabling attackers to exploit weaknesses in TLS/SSL processing or cryptographic operations. This vulnerability has been identified by the vendor as: V-2023-021 — Out-of-Date OpenSSL Library.

References

Community reviews

Loading reviews…