CVE-2025-34316: IPFire · XSS or 'Cross-site Scripting'
Affects IPFireSource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.29 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade IPFire to 2.29.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| IPFire.org IPFire | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, European organizations should immediately upgrade IPFire installations to version 2.29 (Core Update 198) or later, where the issue is resolved. If immediate upgrading is not feasible, administrators should restrict access to the mail configuration interface to trusted users only and enforce strong authentication mechanisms to limit the number of users who can exploit the vulnerability. Implementing web application firewalls (WAFs) that can detect and block malicious script injections targeting the affected parameters may provide temporary protection. Additionally, organizations should audit user permissions to ensure only necessary personnel have access to sensitive configuration pages. Regular monitoring of firewall logs and user activity can help detect suspicious behavior indicative of exploitation attempts. Finally, educating administrators about the risks of stored XSS and encouraging cautious handling of configuration inputs can reduce the likelihood of successful attacks.
Description
IPFire versions prior to 2.29 (Core Update 198) contain a stored cross-site scripting (XSS) vulnerability that allows an authenticated attacker to inject arbitrary JavaScript code through the txt_mailuser and txt_mailpass parameters when updating the mail server settings. When a user updates the mail server, the application issues an HTTP POST request to /cgi-bin/mail.cgi and the username and password are provided in the txt_mailuser and txt_mailpass parameters. The values of these parameters are stored and later rendered in the web interface without proper sanitation or encoding, allowing injected scripts to execute in the context of other users who view the affected mail configuration.