CVE-2025-34522: Arcserve Unified Data Protection (UDP) · Heap-based Buffer Overflow
Affects Arcserve Unified Data Protection (UDP)Source CVE Database V5
Not known to be exploited · CVSS 9.2 Critical · fixed in 10.2 : patch Arcserve Unified Data Protection (UDP) as a priority.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Arcserve Unified Data Protection (UDP) | Affected
| Fixed in– |
AI-suggested
Arcserve UDP version 10.2 includes an official fix that fully remediates this vulnerability. Users running supported versions 8.0 through 10.1 should apply the patch or upgrade to version 10.2 immediately. Systems running unsupported versions 7.x or earlier must upgrade to version 10.2 to address the issue. No other mitigations are indicated or required beyond applying the official patch or upgrade.
Description
A heap-based buffer overflow vulnerability exists in the input parsing logic of Arcserve Unified Data Protection (UDP). This flaw can be triggered without authentication by sending specially crafted input to the target system. Improper bounds checking allows an attacker to overwrite heap memory, potentially leading to application crashes or remote code execution. Exploitation occurs in the context of the affected process and does not require user interaction. The vulnerability poses a high risk due to its pre-authentication nature and potential for full compromise. This vulnerability affects all UDP versions prior to 10.2. UDP 10.2 includes the necessary patches and requires no action. Versions 8.0 through 10.1 are supported and require either patch application or upgrade to 10.2. Versions 7.x and earlier are unsupported or out of maintenance and must be upgraded to 10.2 to remediate the issue.