Skip to main content
CVE-2025-3581VulnerabilityPublished Updated

CVE-2025-3581: Newsletter (WordPress plugin) · Cross-Site Scripting (XSS)

Affects Newsletter (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 4.8 Medium.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Unknown NewsletterAffected
  • =0
Fixed in–

AI-suggested

European organizations should immediately verify if their WordPress installations use the Newsletter plugin and determine the version in use. Upgrading to version 8.8.5 or later, once available, is the primary mitigation step. Until a patch is released, administrators should restrict high privilege user access to trusted personnel only and audit existing widget configurations for suspicious or unexpected content. Implementing Web Application Firewall (WAF) rules to detect and block suspicious script payloads in widget options can provide temporary protection. Additionally, organizations should enforce strict Content Security Policies (CSP) to limit the execution of unauthorized scripts. Regular security training for administrators on the risks of stored XSS and safe content management practices is recommended. Monitoring logs for unusual admin activity and scanning the site for injected scripts can help detect exploitation attempts early. Finally, consider isolating multisite environments or limiting widget usage in sensitive contexts until the vulnerability is resolved.

Description

The Newsletter WordPress plugin before 8.8.5 does not validate and escape some of its Widget options before outputting them back in a page/post where the block is embed, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

References

Community reviews

Loading reviews…