CVE-2025-36580: Dell Wyse Management Suite · Cross-site Scripting
Affects Dell Wyse Management SuiteSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.2 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Dell Wyse Management Suite to 5.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Dell Wyse Management Suite | Affected
| Fixed in
|
AI-suggested
- Upgrade Dell Wyse Management Suite to version 5.2 or later as soon as the patch becomes available to remediate the vulnerability.
- Restrict remote access to the management console using network segmentation, VPNs, and firewall rules to limit exposure to trusted administrators only.
- Enforce strong authentication mechanisms and monitor for unusual high-privilege account activities to detect potential misuse.
- Implement Content Security Policy (CSP) headers and input validation/sanitization on the web application layer to reduce the risk of script injection.
- Conduct regular security assessments and penetration testing focused on web application vulnerabilities in management platforms.
- Educate administrators about the risks of XSS and the importance of cautious interaction with web interfaces, especially when handling untrusted input.
- Monitor vendor advisories closely for official patches and apply them promptly once released.
Description
Dell Wyse Management Suite, versions prior to WMS 5.2, contain an Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Script injection