Skip to main content
VulnerabilityPublished Updated

CVE-2025-3919: Comments Import & Export (WordPress plugin) · Cross-site Scripting

Affects Comments Import & Export (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 2.4.3 : update Comments Import & Export (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
webtoffee Comments Import & ExportAffected
  • =0
  • <=2.4.3
Fixed in–

AI-suggested

Upgrade the Comments Import & Export plugin to version 2.4.4 or later, where the vulnerability is fully fixed. Versions up to 2.4.3 are vulnerable, with only partial fixes in 2.4.3. No other mitigations are indicated.

Description

The WordPress Comments Import & Export plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_settings function in all versions up to, and including, 2.4.3. Additionally, the plugin fails to properly sanitize and escape FTP settings parameters. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts on the plugin settings page that will execute whenever an administrative user accesses an injected page. The vulnerability was partially fixed in version 2.4.3 and fully fixed in version 2.4.4

References

Community reviews

Loading reviews…