Skip to main content
VulnerabilityPublished Updated

CVE-2025-39985: Linux kernel · can: mcba_usb: populate ndo_change_mtu() to prevent buffer overflow

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:20 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1 +68
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-6.6
Fixed in
  • 6.17.0-6.6
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1006.6
Fixed in
  • 6.17.0-1006.6
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1003.3
Fixed in
  • 6.17.0-1003.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed versions include 5.15.0-1100.107~20.04.2 and later. Users should apply the official Linux kernel updates provided by their distribution, such as the Ubuntu security notice USN-8033-1. After updating, a system reboot is required. The fix populates ndo_change_mtu() to prevent invalid MTU settings and thus blocks the buffer overflow condition.

Description

A buffer overflow vulnerability exists in the Linux kernel's mcba_usb CAN driver due to the lack of proper MTU validation. An attacker can set an invalid MTU and inject malicious CAN XL frames via a PF_PACKET socket, causing the driver to misinterpret frame data and overflow a buffer. This flaw has been fixed by populating the ndo_change_mtu() function to enforce valid MTU limits.

References

Community reviews

Loading reviews…