Skip to main content
VulnerabilityPublished Updated

CVE-2025-40087: Linux kernel · NFSD: Define a proc_layoutcommit for the FlexFiles layout type

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.

Data as of 28 Oct 2026, 11:18 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1 +71
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and included in Linux kernel versions 5.15.0-1094.97~20.04.1 and later. Users and administrators should update to these fixed kernel versions or later to remediate this vulnerability. The Ubuntu security advisory USN-8029-1 provides official updates addressing this and other kernel issues.

Description

CVE-2025-40087 is a vulnerability in the Linux kernel's NFSD subsystem related to the FlexFiles layout type. It addresses a crash that could occur if a pNFS client sends a LAYOUTCOMMIT operation on a FlexFiles layout. The issue has been fixed in multiple Linux kernel versions starting from 5.15.0-1094.97~20.04.1 and later. The vulnerability has a high severity score and does not involve confidentiality or integrity impacts but can cause denial of service via a crash.

References

Community reviews

Loading reviews…