Skip to main content
VulnerabilityPublished Updated

CVE-2025-40118: Linux kernel · scsi: pm80xx: Fix array-index-out-of-of-bounds on rmmod

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.8 High · fixed in 5.15.0-1100.107~20.04.2 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:19 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.15.0-1100.107~20.04.2, 5.15.0-1110.119~20.04.1, 5.15.0-1100.109~20.04.1 +69
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 25.10linuxpkg:deb/ubuntu/linux?arch=source&distro=questingOther threatsAffected
  • <6.17.0-14.14
Fixed in
  • 6.17.0-14.14
Ubuntu 25.10linux-awspkg:deb/ubuntu/linux-aws?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-azurepkg:deb/ubuntu/linux-azure?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1008.8
Fixed in
  • 6.17.0-1008.8
Ubuntu 25.10linux-azure-fdepkg:deb/ubuntu/linux-azure-fde?arch=source&distro=questingOther threatsAffected
  • 6.17.0-1003.3 – 6.17.0-1017.17
10 affected builds
Fixed in–
Ubuntu 25.10linux-gcppkg:deb/ubuntu/linux-gcp?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7
Ubuntu 25.10linux-oraclepkg:deb/ubuntu/linux-oracle?arch=source&distro=questingOther threatsAffected
  • <6.17.0-1007.7
Fixed in
  • 6.17.0-1007.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and has been released in multiple Linux kernel versions starting from 5.15.0-1094.97 and related updates. Users and administrators should upgrade to these fixed kernel versions to remediate the vulnerability. No alternative mitigations are indicated by the vendor advisory.

Description

CVE-2025-40118 is a high-severity vulnerability in the Linux kernel's SCSI pm80xx driver. It involves an array index out-of-bounds error triggered during module removal (rmmod) when using an expander device. The flaw arises because the driver incorrectly uses a remote phy ID to index a local phy array, leading to out-of-bounds access. This issue has been fixed in multiple Linux kernel versions starting from 5.15.0-1094.97 and related releases.

References

Community reviews

Loading reviews…