Skip to main content
CVE-2025-4102VulnerabilityPublished Updated

CVE-2025-4102: The Beaver Builder Team Beaver Builder Plugin (Starter Version) · Unrestricted File Upload

Affects The Beaver Builder Team Beaver Builder Plugin (Starter Version)Source CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 2.9.1 : patch The Beaver Builder Team Beaver Builder Plugin (Starter Version) soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.9.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
The Beaver Builder Team Beaver Builder Plugin (Starter Version)Affected
  • =0
Fixed in–

AI-suggested

A partial patch was applied in version 2.9.1 of the Beaver Builder Plugin (Starter Version), but no complete fix or patch link is currently available. Until a full fix is released, restrict Administrator access to trusted users only and consider additional security controls to limit file upload capabilities.

Description

The Beaver Builder Plugin (Starter Version) plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'save_enabled_icons' function in all versions up to, and including, 2.9.1. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 2.9.1.

References

Community reviews

Loading reviews…