CVE-2025-43964: LibRaw · Improper Validation of Specified Quantity in Input
Affects LibRawSource GCVE Database
Not known to be exploited · CVSS 2.9 Low : upgrade to 0.21.4 when convenient.
Data as of 30 Oct 2026, 00:17 UTC
Thin evidence
One scorer or none| CNA (mitre) | CVSS 3.1 | 2.9 |
|---|
- Patch
- Available – fixed in 0.21.4
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade LibRaw to 0.21.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| LibRaw LibRaw | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, avoid processing untrusted inputs that could trigger the vulnerability.
Description
CVE-2025-43964 is a low-severity vulnerability in LibRaw before version 0.21.4 where the processing of tag 0x412 in the phase_one_correct function does not enforce minimum values for parameters w0 and w1. This improper validation could lead to a denial of service due to an availability impact.