CVE-2025-4439: GitLab · Cross-site Scripting
Affects GitLabSource CVE Database V5
Not known to be exploited · CVSS 7.7 High · fixed in 18.2.1 : patch GitLab soon.
Data as of 3 Nov 2026, 22:58 UTC
Thin evidence
One scorer or none| CNA (GitLab) | CVSS 3.1 | 7.7 |
|---|
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2025-07-25.
- Patch
- Available – fixed in 18.2.1, 18.1.3, 18.0.5
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 23 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade GitLab to 18.2.1, 18.1.3 or 18.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*
AI-suggested
Upgrading GitLab CE/EE to versions 18.0.5, 18.1.3, or 18.2.1 or later fully mitigates this vulnerability. Users should apply these official fixes to prevent exploitation. No additional mitigations are specified or required beyond applying the patches.
Description
CVE-2025-4439 is a high-severity cross-site scripting (XSS) vulnerability in GitLab CE/EE affecting versions from 15.10 up to but not including 18.0.5, 18.1 up to 18.1.3, and 18.2 up to 18.2.1. The flaw allows an authenticated user to perform XSS attacks when the GitLab instance is served through certain content delivery networks. This vulnerability has been fixed in versions 18.0.5, 18.1.3, and 18.2.1.