Skip to main content
CVE-2025-1763VulnerabilityPublished

CVE-2025-1763: GitLab · Cross-site Scripting

Affects GitLabSource CVE Database V5

0

Not known to be exploited · CVSS 8.7 High · fixed in 17.11.1 : patch GitLab soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.11.1, 17.10.5, 17.9.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab-org/gitlab to 17.11.1, 17.10.5 or 17.9.7.

Affected software

ProductAffectedFixed in
GitHubgitlab-org/gitlabpkg:github/gitlab-org/gitlabOther threatsAffected
  • >=16.6 <17.9.7
  • >=17.10 <17.10.5
  • >=17.11 <17.11.1
  • =16.6
  • =17.10
  • =17.11
Fixed in
  • 17.9.7
  • 17.10.5
  • 17.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should prioritize upgrading GitLab EE installations to versions 17.9.7, 17.10.5, 17.11.1, or later, where this vulnerability is patched. Until upgrades can be applied, organizations should enforce strict access controls to limit user privileges, minimizing the number of users with write or administrative permissions. Implementing multi-factor authentication (MFA) can reduce the risk of account compromise that could lead to exploitation. Review and tighten Content Security Policy configurations to mitigate script injection risks, although CSP bypass is possible, a robust policy may still reduce attack surface. Conduct thorough audits of user-generated content and inputs that interact with GitLab web interfaces to detect and sanitize potentially malicious inputs. Monitoring GitLab logs for unusual activity or attempted exploitation attempts is recommended. Additionally, educating developers and users about phishing and social engineering risks can help prevent attackers from gaining the necessary user interaction to exploit the vulnerability. Network segmentation to isolate GitLab servers and restrict access to trusted users can further reduce exposure. Finally, maintain up-to-date backups of repositories and configurations to enable recovery in case of compromise.

Description

An issue has been discovered in GitLab EE that allows for cross-site-scripting attack and content security policy bypass in a user's browser under specific conditions, affecting all versions from 16.6 before 17.9.7, 17.10 before 17.10.5, and 17.11 before 17.11.1.

References

Community reviews

Loading reviews…