Skip to main content
VulnerabilityPublished Updated

CVE-2025-46295: Claris FileMaker Server · Code Injection

Affects Claris FileMaker ServerSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.10.0 as a priority.

Data as of 26 Oct 2026, 11:07 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.commons/commons-text to 1.10.0.

Affected software

ProductAffectedFixed in
Mavenorg.apache.commons/commons-textpkg:maven/org.apache.commons/commons-textOther threatsAffected
  • <1.10.0
Fixed in
  • 1.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-46295, organizations should immediately upgrade Claris FileMaker Server to version 22.0.4 or later, where the vulnerability is fully addressed. If immediate upgrade is not feasible, restrict network access to FileMaker Server instances by implementing strict firewall rules and network segmentation to limit exposure. Review and sanitize all inputs passed to the text-substitution API to ensure untrusted data is never processed by vulnerable interpolation features. Employ application-layer controls to detect and block suspicious command execution attempts. Monitor server logs for unusual activity indicative of exploitation attempts. Additionally, consider deploying runtime application self-protection (RASP) or endpoint detection and response (EDR) solutions to detect and prevent exploitation. Maintain an up-to-date inventory of software dependencies and apply security patches promptly. Educate developers and administrators about the risks of unsafe interpolation and the importance of secure coding practices.

Description

Apache Commons Text versions prior to 1.10.0 included interpolation features that could be abused when applications passed untrusted input into the text-substitution API. Because some interpolators could trigger actions like executing commands or accessing external resources, an attacker could potentially achieve remote code execution. This vulnerability has been fully addressed in FileMaker Server 22.0.4.

References

Community reviews

Loading reviews…