CVE-2025-4652: Broadstreet (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Broadstreet (WordPress plugin)Source CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 6.1 Medium · fixed in 1.51.8 : update Broadstreet (WordPress plugin) when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.51.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2025
Detectable: evidence found.
nuclei template: Broadstreet WordPress plugin - Reflected XSS
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Unknown Broadstreet | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify their use of the Broadstreet WordPress plugin and upgrade to version 1.51.8 or later where the vulnerability is fixed. Until patching is possible, organizations should implement Web Application Firewall (WAF) rules to detect and block suspicious input patterns that could trigger XSS payloads. Administrators should be trained to recognize phishing attempts that might exploit this vulnerability. Additionally, applying Content Security Policy (CSP) headers can help mitigate the impact by restricting the execution of unauthorized scripts. Regular security audits and scanning for reflected XSS vulnerabilities on public-facing web assets should be conducted. Finally, limiting admin access to trusted networks and enforcing multi-factor authentication can reduce the risk of session hijacking if exploitation occurs.
Description
The Broadstreet WordPress plugin before 1.51.8 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.