Skip to main content
VulnerabilityPublished Updated

CVE-2025-4691: eaSYNC Booking (WordPress plugin) · Insecure Direct Object Reference

Affects eaSYNC Booking (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 1.3.18 : update eaSYNC Booking (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.18
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
syntactics eaSYNC Booking – Hotels, Restaurants & Car RentalsAffected
  • =0
Fixed in–

AI-suggested

Partial patches exist in versions 1.3.18 and 1.3.21; however, no complete fix is confirmed. Users should upgrade to the latest plugin version if available and monitor vendor advisories for a full patch. Until a full fix is released, restrict access to the plugin's booking request details page and consider additional access controls to mitigate unauthorized viewing.

Description

The Free Booking Plugin for Hotels, Restaurants and Car Rentals – eaSYNC Booking plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 1.3.21 via the 'view_request_details' due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to view the details of any booking request. The vulnerability was partially patched in versions 1.3.18 and 1.3.21.

References

Community reviews

Loading reviews…