Skip to main content
VulnerabilityPublished Updated

CVE-2025-4754: team-alembic ash_authentication_phoenix · Insufficient Session Expiration

Affects team-alembic ash_authentication_phoenixSource CVE Database V5

0

Not known to be exploited · CVSS 2.3 Low : upgrade to 2.10.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.10.0, a3253fb4fc7145aeb403537af1c24d3a8d51ffb1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ash_authentication_phoenix and ash-project/ash_authentication_phoenix to 2.10.0; ash_authentication_phoenix to a3253fb4fc7145aeb403537af1c24d3a8d51ffb1.

Affected software

ProductAffectedFixed in
team-alembicash_authentication_phoenixAffected
  • >=0.1.0 <2.10.0
Fixed in
  • 2.10.0
team-alembicash_authentication_phoenixAffected
  • ≥ 05ab4f438bf0cd0fdfb279d912bbe0d2c3620e02, < a3253fb4fc7145aeb403537af1c24d3a8d51ffb1
Fixed in
  • a3253fb4fc7145aeb403537af1c24d3a8d51ffb1
Hexash-project/ash_authentication_phoenixpkg:hex/ash-project/ash_authentication_phoenixOther threatsAffected
  • <2.10.0
Fixed in
  • 2.10.0
Hexash_authentication_phoenixpkg:hex/ash_authentication_phoenixOther threatsAffected
  • >=0.1.0 <2.10.0
Fixed in
  • 2.10.0

CPE configurations (1)

  • cpe:2.3:a:team-alembic:ash_authentication_phoenix:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should consider implementing additional session management controls or monitoring for unusual session activity as a precaution.

Description

Insufficient Session Expiration vulnerability in team-alembic ash_authentication_phoenix allows a session token captured before sign-out to remain usable afterwards. The default sign_out/2 that AshAuthentication.Phoenix.Controller injects into an application's auth controller only calls Plug.Conn.clear_session/1. It never revokes the stored session or bearer tokens, so a token obtained before sign-out, through script injection, interception or device theft, keeps authenticating until its own expiry. Changing the password still revokes it. This issue affects ash_authentication_phoenix: from 0.1.0 before 2.10.0.

References

Community reviews

Loading reviews…