Skip to main content
VulnerabilityPublished

CVE-2025-47773: Combodo iTop · Cross-site Scripting

Affects Combodo iTopSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 3.2.3 or 2.7.13 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.3, 2.7.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade combodo/iTop to 3.2.3 or 2.7.13.

Affected software

ProductAffectedFixed in
GitHubcombodo/iToppkg:github/combodo/iTopOther threatsAffected
  • <2.7.13
  • >=3.0.0 <3.2.3
Fixed in
  • 2.7.13
  • 3.2.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-47773, organizations should immediately upgrade Combodo iTop installations to versions 2.7.13 or 3.2.2, where the vulnerability is patched. If immediate upgrading is not feasible, restrict dashboard editing privileges to trusted administrators only, minimizing the attack surface. Implement robust input validation and sanitization on all user-supplied data, especially in AJAX endpoints handling dashboard modifications. Deploy Content Security Policies (CSP) to limit the execution of unauthorized scripts in browsers. Monitor web application logs for unusual AJAX requests or suspicious dashboard edits that could indicate exploitation attempts. Conduct regular security assessments and penetration testing focused on web application vulnerabilities. Additionally, educate users about the risks of interacting with untrusted dashboards or links. Network segmentation and application-layer firewalls can further reduce exposure by limiting access to the iTop interface. Finally, maintain an incident response plan tailored to web application attacks to quickly detect and respond to potential exploitation.

Description

CVE-2025-47773 is a high-severity cross-site scripting (XSS) vulnerability affecting Combodo iTop versions prior to 2.7.13 and between 3.0.0-alpha and 3.2.2. The flaw arises from improper neutralization of input during web page generation when dashboards are edited via AJAX calls, allowing attackers to inject malicious scripts. Successful exploitation can lead to full compromise of confidentiality, integrity, and availability of affected systems without requiring authentication but does require user interaction. Although no known exploits are currently observed in the wild, the vulnerability's CVSS score of 8.

References

Community reviews

Loading reviews…