CVE-2025-47849: Apache CloudStack · Improper Privilege Management
Affects Apache CloudStackSource CVE Database V5
Not known to be exploited · CVSS 8.8 High.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.cloudstack/cloudstackpkg:maven/org.apache.cloudstack/cloudstackOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-47849, organizations should immediately upgrade Apache CloudStack to versions 4.19.3.0 or 4.20.1.0, which contain the necessary security fixes. Beyond upgrading, administrators should audit and restrict Domain Admin privileges, minimizing the number of users with such roles. Implement strict role separation policies and monitor API key usage for anomalies. Configure the new domain-level settings introduced by Apache to limit operations on accounts of the same role type and within the same account, reducing the attack surface. Regularly review and enforce the principle of least privilege for all user roles. Employ comprehensive logging and alerting on privilege escalation attempts and API key access. Conduct penetration testing and security assessments focused on role-based access controls within CloudStack environments. Finally, maintain up-to-date backups and incident response plans to quickly recover from potential compromises.
Description
A privilege escalation vulnerability exists in Apache CloudStack versions 4.10.0.0 through 4.20.0.0 where a malicious Domain Admin user in the ROOT domain can get the API key and secret key of user-accounts of Admin role type in the same domain. This operation is not appropriately restricted and allows the attacker to assume control over higher-privileged user-accounts. A malicious Domain Admin attacker can impersonate an Admin user-account and gain access to sensitive APIs and resources that could result in the compromise of resource integrity and confidentiality, data loss, denial of service, and availability of infrastructure managed by CloudStack. Users are recommended to upgrade to Apache CloudStack 4.19.3.0 or 4.20.1.0, which fixes the issue with the following: * Strict validation on Role Type hierarchy: the caller's role must be equal to or higher than the target user's role. * API privilege comparison: the caller must possess all privileges of the user they are operating on. * Two new domain-level settings (restricted to the default admin): - role.types.allowed.for.operations.on.accounts.of.same.role.type: Defines which role types are allowed to act on users of the same role type. Default: "Admin, DomainAdmin, ResourceAdmin". - allow.operations.on.users.in.same.account: Allows/disallows user operations within the same account. Default: true.