Skip to main content
VulnerabilityPublished Updated

CVE-2025-48068: vercel next.js · Missing Origin Validation in WebSockets

Affects vercel next.jsSource CVE Database V5

0

Not known to be exploited · CVSS 2.3 Low : upgrade to 15.2.2 or 14.2.30 when convenient.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.2.2, 14.2.30
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade next to 15.2.2 or 14.2.30.

Affected software

ProductAffectedFixed in
npmnextpkg:npm/nextOther threatsAffected
  • >=13.0.0 <14.2.30
  • =15.0.0 <15.2.2
Fixed in
  • 14.2.30
  • 15.2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should take the following specific actions: 1) Upgrade all Next.js development environments to version 14.2.30 or later, or 15.2.2 or later, where the vulnerability is patched. 2) Educate developers about the risks of running development servers exposed to untrusted networks or visiting unknown websites while the dev server is active. 3) Implement network segmentation or firewall rules to restrict access to development servers, ensuring they are not reachable from external or untrusted networks. 4) Use secure development practices such as running development environments within isolated containers or virtual machines to limit exposure. 5) Monitor developer workstations for unusual network activity during development sessions. 6) Encourage the use of VPNs or secure tunnels when remote development is necessary to reduce exposure to malicious web content. 7) Incorporate security scanning tools in the development pipeline to detect outdated dependencies and enforce timely updates. These measures go beyond generic advice by focusing on controlling the development environment exposure and developer behavior, which are critical given the nature of this vulnerability.

Description

Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.

References

Community reviews

Loading reviews…