Skip to main content
VulnerabilityPublished Updated

CVE-2025-48385: git · Argument Injection

Affects gitSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.6 High · fixed in 2.50.1 : patch git soon.

Data as of 4 Nov 2026, 17:32 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.6
Patch
Available – fixed in 2.50.1, 2.49.1, 2.48.2 +5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
git gitAffected
  • <2.43.7
  • >=2.44.0-rc0 <2.44.4
  • >=2.45.0-rc0 <2.45.4
  • >=2.46.0-rc0 <2.46.4
  • >=2.47.0-rc0 <2.47.3
  • >=2.48.0-rc0 <2.48.2
  • >=2.49.0-rc0 <2.49.1
  • >=2.50.0-rc0 <2.50.1
Fixed in
  • 2.43.7
  • 2.44.4
  • 2.45.4
  • 2.46.4
  • 2.47.3
  • 2.48.2
  • 2.49.1
  • 2.50.1

AI-suggested

Upgrade Git to one of the fixed versions: 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, or 2.50.1. Alternatively, disable the bundle URI feature by ensuring the bundle.heuristic configuration option is not enabled and avoid recursive cloning to prevent attack vectors that require control over the clone destination. These mitigations reduce the risk of exploitation.

Description

CVE-2025-48385 is a high-severity vulnerability in Git that allows a remote attacker to perform protocol injection via insufficient validation of advertised bundles during repository cloning. This can lead to the client writing attacker-controlled content to arbitrary locations, potentially resulting in arbitrary code execution. The vulnerability requires the use of bundle URIs, which are not enabled by default, and some attack scenarios require control over the clone destination or recursive cloning. Multiple fixed versions have been released to address this issue.

References

Community reviews

Loading reviews…