Skip to main content
VulnerabilityPublished Updated

CVE-2025-48386: git · Classic Buffer Overflow

Affects gitSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.3 Medium · fixed in 2.50.1 : update git when convenient.

Data as of 4 Nov 2026, 17:32 UTC

CVSS 3.1 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.16.3
Patch
Available – fixed in 2.50.1, 2.49.1, 2.48.2 +5
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
git gitAffected
  • <2.43.7
  • >=2.44.0-rc0 <2.44.4
  • >=2.45.0-rc0 <2.45.4
  • >=2.46.0-rc0 <2.46.4
  • >=2.47.0-rc0 <2.47.3
  • >=2.48.0-rc0 <2.48.2
  • >=2.49.0-rc0 <2.49.1
  • >=2.50.0-rc0 <2.50.1
Fixed in
  • 2.43.7
  • 2.44.4
  • 2.45.4
  • 2.46.4
  • 2.47.3
  • 2.48.2
  • 2.49.1
  • 2.50.1

AI-suggested

This vulnerability is fixed in Git versions 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1. Users should upgrade to one of these versions or later to remediate the issue.

Description

CVE-2025-48386 is a classic buffer overflow vulnerability in Git's wincred credential helper. The issue arises because the helper uses a static buffer without properly checking bounds before appending data, leading to potential overflow. This flaw is fixed in multiple Git versions starting from 2.43.7 and several subsequent patch releases. The vulnerability has a CVSS score of 6.3, indicating medium severity, and impacts confidentiality but not integrity or availability.

References

Community reviews

Loading reviews…