Skip to main content
VulnerabilityPublished Updated

CVE-2025-48390: freescout · Code Injection

Affects freescoutSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 1.8.178 soon.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.8.178
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade freescout-help-desk/freescout to 1.8.178.

Affected software

ProductAffectedFixed in
GitHubfreescout-help-desk/freescoutpkg:github/freescout-help-desk/freescoutOther threatsAffected
  • <1.8.178
Fixed in
  • 1.8.178

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Immediate upgrade of FreeScout to version 1.8.178 or later to apply the official patch that fixes the input validation flaw.
  2. Restrict administrator privileges strictly to trusted personnel and enforce strong authentication mechanisms such as multi-factor authentication to reduce the risk of credential compromise.
  3. Conduct regular audits of administrator activities and monitor for unusual creation of language translations or modifications to the php_path parameter in tools.php.
  4. Implement application-level input validation and sanitization controls to detect and block malicious input patterns, including backticks and other shell metacharacters.
  5. Employ web application firewalls (WAFs) with custom rules to detect and block attempts to exploit this vulnerability by monitoring for suspicious parameters in HTTP requests.
  6. Isolate FreeScout servers within segmented network zones with limited access to critical internal systems to contain potential breaches.
  7. Maintain up-to-date backups of FreeScout data and configurations to enable rapid recovery in case of compromise.
  8. Educate administrators on secure configuration and the risks of code injection vulnerabilities to prevent inadvertent exposure.

Description

FreeScout is a free self-hosted help desk and shared mailbox. Prior to version 1.8.178, FreeScout is vulnerable to code injection due to insufficient validation of user input in the php_path parameter. The backticks characters are not removed, as well as tabulation is not removed. When checking user input, the file_exists function is also called to check for the presence of such a file (folder) in the file system. A user with the administrator role can create a translation for the language, which will create a folder in the file system. Further in tools.php, the user can specify the path to this folder as php_path, which will lead to the execution of code in backticks. This issue has been patched in version 1.8.178.

References

Community reviews

Loading reviews…