Skip to main content
CVE-2025-48492VulnerabilityPublished

CVE-2025-48492: GetSimpleCMS-CE · Command Injection

Affects GetSimpleCMS-CESource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 3.3.22 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.3.22
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade getsimplecms-ce/GetSimpleCMS-CE to 3.3.22.

Affected software

ProductAffectedFixed in
GitHubgetsimplecms-ce/GetSimpleCMS-CEpkg:github/getsimplecms-ce/GetSimpleCMS-CEOther threatsAffected
  • >=3.3.16 <3.3.22
Fixed in
  • 3.3.22

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade to GetSimpleCMS-CE version 3.3.22 once it is released, as this version will contain the official patch addressing the vulnerability. 2. If you cannot patch yet, restrict access to the 'Edit component' functionality to only the most trusted and essential users, minimizing the number of authenticated users who can exploit the vulnerability. 3. Implement Web Application Firewall (WAF) rules to detect and block suspicious query strings that attempt to inject PHP code or unusual command patterns targeting component files. 4. Conduct regular code audits and input validation reviews on custom components or plugins to ensure no additional injection vectors exist. 5. Monitor web server logs and CMS activity logs for unusual behavior, such as unexpected query strings or file modifications, to detect potential exploitation attempts early. 6. Employ network segmentation to isolate CMS servers from critical internal networks, limiting lateral movement if a compromise occurs. 7. Backup CMS data and configuration regularly, ensuring that recovery is possible in case of compromise. 8. Educate authenticated users about the risks of phishing or credential compromise that could enable attackers to gain authenticated access.

Description

GetSimple CMS is a content management system. In versions starting from 3.3.16 to 3.3.21, an authenticated user with access to the Edit component can inject arbitrary PHP into a component file and execute it via a crafted query string, resulting in Remote Code Execution (RCE). This issue is set to be patched in version 3.3.22.

References

Community reviews

Loading reviews…