Skip to main content
VulnerabilityPublished

CVE-2025-48877: discourse · Insecure Automated Optimizations

Affects discourseSource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 3.4.4 soon.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade discourse/discourse to 3.4.4.

Affected software

ProductAffectedFixed in
GitHubdiscourse/discoursepkg:github/discourse/discourseOther threatsAffected
  • <3.4.4
Fixed in
  • 3.4.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should promptly upgrade Discourse installations to version 3.4.4 or later (stable), 3.5.0.beta5 or later (beta), or 3.5.0.beta6-dev or later (tests-passed) to apply the official patch. As an immediate workaround, administrators can remove the Codepen prefix from the 'allowed_iframes' site setting to disable the automatic execution of JavaScript within Codepen iframes. Additionally, organizations should audit their Discourse configurations to ensure no other iframe sources allow unintended script execution. Implement Content Security Policy (CSP) headers to restrict iframe sources and script execution contexts. Regularly monitor Discourse logs for unusual iframe activity or script injections. Educate forum moderators and users about potential phishing or social engineering attempts leveraging this vulnerability. Finally, maintain an inventory of Discourse instances and ensure timely patch management aligned with security advisories.

Description

Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.

References

Community reviews

Loading reviews…