Skip to main content
VulnerabilityPublished

CVE-2025-48883: chrome · Cross-site Scripting

Affects chromeSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.14.0 when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.14.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade chrome-php/chrome to 1.14.0.

Affected software

ProductAffectedFixed in
GitHubchrome-php/chromepkg:github/chrome-php/chromeOther threatsAffected
  • <1.14.0
Fixed in
  • 1.14.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-48883, European organizations should promptly upgrade chrome-php to version 1.14.0 or later, where the vulnerability is patched. If upgrading is not immediately feasible, developers must ensure that all CSS Selector expressions are properly encoded before use to neutralize potentially malicious input. This can be achieved by implementing strict input validation and output encoding routines specifically targeting CSS selectors within the PHP codebase. Additionally, organizations should review their use of chrome-php in automation and web applications to identify any exposure to untrusted input that could be exploited. Employing Content Security Policy (CSP) headers can further reduce the risk of XSS by restricting script execution sources. Regular security code reviews and automated scanning for XSS patterns in the code handling CSS selectors are recommended. Finally, user awareness training to recognize phishing attempts can reduce the likelihood of successful exploitation requiring user interaction.

Description

Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.

References

Community reviews

Loading reviews…