Skip to main content
CVE-2025-48887VulnerabilityPublished

CVE-2025-48887: vllm · ReDoS

Affects vllmSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.9.0 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade vllm to 0.9.0.

Affected software

ProductAffectedFixed in
PyPIvllmpkg:pypi/vllmOther threatsAffected
  • <0.9.0 >=0.6.4
Fixed in
  • 0.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their deployments of vLLM and identify any instances running versions between 0.6.4 and 0.9.0. The primary mitigation is to upgrade to vLLM version 0.9.0 or later, which contains the patch addressing the ReDoS vulnerability. If immediate upgrading is not feasible, organizations should implement input validation and sanitization to detect and block maliciously crafted inputs that could trigger catastrophic backtracking. Rate limiting and request throttling can reduce the impact of potential attacks by limiting the number of regex evaluations per client or IP address. Monitoring CPU usage and response times on vLLM services can help detect ongoing exploitation attempts. Network-level protections such as Web Application Firewalls (WAFs) with custom rules to identify suspicious payloads targeting the vulnerable regex pattern may also be effective. Finally, organizations should incorporate this vulnerability into their incident response and vulnerability management workflows to ensure timely patching and detection.

Description

vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py` of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.

References

Community reviews

Loading reviews…