Skip to main content
VulnerabilityPublished

CVE-2025-48912: Apache Superset · SQL Injection

Affects Apache SupersetSource CVE Database V5

0

Not known to be exploited · CVSS 7.1 High : upgrade to 4.1.2 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apache-superset to 4.1.2.

Affected software

ProductAffectedFixed in
PyPIapache-supersetpkg:pypi/apache-supersetOther threatsAffected
  • <4.1.2
Fixed in
  • 4.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Superset to version 4.1.2 or later, where this vulnerability is fixed. No other mitigations are indicated.

Description

CVE-2025-48912 is a high-severity SQL injection vulnerability in Apache Superset before version 4.1.2. An authenticated attacker can inject SQL into 'sqlExpression' fields to bypass row level security and gain unauthorized data access. The issue is fixed in version 4.1.2.

References

Community reviews

Loading reviews…