Skip to main content
CVE-2025-48942VulnerabilityPublished

CVE-2025-48942: vllm · Uncaught Exception

Affects vllmSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.9.0 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.9.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade vllm-project/vllm to 0.9.0.

Affected software

ProductAffectedFixed in
GitHubvllm-project/vllmpkg:github/vllm-project/vllmOther threatsAffected
  • <0.9.0 >=0.8.0
Fixed in
  • 0.9.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should upgrade vLLM to version 0.9.0 or later, where this vulnerability is fixed. Until upgrading is possible, organizations can implement strict input validation and filtering at the API gateway or web application firewall (WAF) level to detect and block malformed JSON schema inputs targeting the /v1/completions endpoint. Rate limiting and anomaly detection on API requests can help identify and mitigate potential exploitation attempts. Monitoring server logs for repeated crashes or malformed requests can provide early warning signs. Restricting access to the API endpoint to trusted networks or authenticated users can reduce exposure. Additionally, organizations should conduct regular vulnerability scans and penetration tests focusing on AI inference services to detect similar issues proactively. Maintaining an incident response plan for service outages related to AI inference engines is also advisable.

Description

vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.

References

Community reviews

Loading reviews…