CVE-2025-48951: auth0-PHP · Deserialization of Untrusted Data
Affects auth0-PHPSource CVE Database V5
Not known to be exploited · CVSS 9.3 Critical : upgrade to 8.3.1 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.3.1, 8.14.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade auth0/auth0-PHP to 8.3.1; auth0/laravel-auth0 and auth0/symfony and auth0/wordpress to 8.14.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubauth0/auth0-PHPpkg:github/auth0/auth0-PHPOther threats | Affected
| Fixed in
|
GitHubauth0/laravel-auth0pkg:github/auth0/laravel-auth0Other threats | Affected
| Fixed in
|
GitHubauth0/symfonypkg:github/auth0/symfonyOther threats | Affected
| Fixed in
|
GitHubauth0/wordpresspkg:github/auth0/wordpressOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately audit their PHP applications to identify usage of auth0-PHP SDK versions between 8.0.0-BETA3 and 8.3.1, including dependent SDKs such as Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress. The primary mitigation step is to upgrade all affected SDKs to version 8.3.1 or later, where the vulnerability has been patched. In parallel, organizations should implement strict cookie validation and integrity checks to detect and reject malformed or suspicious serialized data. Employing web application firewalls (WAFs) with custom rules to detect anomalous cookie payloads can provide an additional layer of defense. Developers should also review deserialization logic to avoid unsafe deserialization patterns and consider using safer serialization formats like JSON where possible. Monitoring application logs for unusual authentication or cookie processing behavior can help detect attempted exploitation. Finally, organizations should ensure that their incident response teams are prepared to respond to potential exploitation attempts and have up-to-date backups to recover from any compromise.
Description
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. Versions 8.0.0-BETA3 prior to 8.3.1 contain a vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Applications using the Auth0-PHP SDK are affected, as are applications using the Auth0/symfony, Auth0/laravel-auth0, or Auth0/wordpress SDKs, because those SDKsrely on the Auth0-PHP SDK versions from 8.0.0-BETA3 until 8.14.0. Version 8.3.1 contains a patch for the issue.
References
- github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492 (opens in a new tab)
- github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q (opens in a new tab)
- github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34 (opens in a new tab)
- github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r (opens in a new tab)
- github.com/auth0/auth0-PHP/commit/04b1f5daa8bdfebc5e740ec5ca0fb2df1648a715 (opens in a new tab)