Skip to main content
VulnerabilityPublished

CVE-2025-48977: Apache Ignite · Relative Path Traversal

Affects Apache IgniteSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High · fixed in 2.18.0 : patch Apache Ignite soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache IgniteAffected
  • >=2.0.0 <=2.17.0
Fixed in–
MavenApache Software Foundation/org.apache.ignite:ignite-rest-httppkg:maven/Apache Software Foundation/org.apache.ignite:ignite-rest-httpOther threatsAffected
  • >=2.0.0 <=2.17.0
Fixed in–
Mavenorg.apache.ignite/ignite-corepkg:maven/org.apache.ignite/ignite-coreOther threatsAffected
  • =2.0.0
  • <=2.17.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Ignite to version 2.18.0 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the vendor advisory recommending upgrade to 2.18.0.

Description

A Relative Path Traversal vulnerability (CWE-23) exists in the Apache Ignite REST API that allows authenticated users to read arbitrary files on the server by exploiting the "cmd=log" command with a specially crafted log path. This affects Apache Ignite versions from 2.0.0 through 2.17.0. The issue is fixed in version 2.18.0. The vulnerability has a high severity with a CVSS 4.0 base score of 8.5.

References

Community reviews

Loading reviews…