Skip to main content
CVE-2025-48992VulnerabilityPublished

CVE-2025-48992: Intermesh groupoffice · Cross-site Scripting

Affects Intermesh groupofficeSource CVE Database V5

0

Not known to be exploited · CVSS 5.2 Medium : upgrade to 25.0.27 or 6.8.123 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.0.27, 6.8.123
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade intermesh/groupoffice to 25.0.27 or 6.8.123.

Affected software

ProductAffectedFixed in
GitHubintermesh/groupofficepkg:github/intermesh/groupofficeOther threatsAffected
  • <6.8.123
  • <25.0.27
Fixed in
  • 6.8.123
  • 25.0.27

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Group-Office installations to versions 6.8.123 or 25.0.27 or later to apply the official patch addressing this vulnerability.

Implement strict input validation and output encoding on all user-supplied data fields, especially those rendered in web pages, to prevent injection of executable scripts.

Enforce the principle of least privilege by restricting user permissions to only those necessary, minimizing the risk of malicious users injecting payloads.

Monitor and audit user profile changes, particularly modifications to the Name Field, to detect suspicious or anomalous inputs that may indicate exploitation attempts.

Configure Content Security Policy (CSP) headers to restrict the execution of inline scripts and limit the sources of executable scripts in the browser context.

Educate users about the risks of adding unknown or untrusted users to synchronization address books and encourage verification of user identities.

Deploy web application firewalls (WAFs) with rules tailored to detect and block XSS payloads targeting Group-Office endpoints.

Regularly review and update authentication mechanisms to prevent account compromise, as exploitation requires authenticated access.

Conduct periodic security assessments and penetration testing focused on web application vulnerabilities to identify and remediate similar issues proactively.

Description

Group-Office is an enterprise customer relationship management and groupware tool. Prior to versions 6.8.123 and 25.0.27, a stored and blind cross-site scripting (XSS) vulnerability exists in the Name Field of the user profile. A malicious attacker can change their name to a javascript payload, which is executed when a user adds the malicious user to their Synchronization > Address books. This issue has been patched in versions 6.8.123 and 25.0.27.

References

Community reviews

Loading reviews…