CVE-2025-49006: wasp · Incorrect Default Permissions
Affects waspSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 0.16.6 soon.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.16.6
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade wasp-lang/wasp to 0.16.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwasp-lang/wasppkg:github/wasp-lang/waspOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediate upgrade of the Wasp framework to version 0.16.6 or later to apply the official fix that corrects OAuth user ID handling. 2. For organizations unable to upgrade immediately, reconfigure Keycloak realms to use case-insensitive user IDs or avoid case-sensitive UUIDs to prevent collisions and impersonation. 3. Conduct an audit of all applications using Wasp with Keycloak to identify affected instances and prioritize patching. 4. Implement strict monitoring and logging of authentication events to detect unusual login patterns or potential impersonation attempts. 5. Enforce multi-factor authentication (MFA) on critical applications to reduce the risk of unauthorized access even if impersonation occurs. 6. Review and tighten access controls and permissions within applications to limit the impact of potential privilege escalation. 7. Educate development and security teams about the importance of adhering to OAuth and OpenID Connect specifications to prevent similar issues in custom implementations. 8. Regularly update and patch all components of the authentication stack, including OAuth providers and frameworks, to minimize exposure to known vulnerabilities.
Description
Wasp (Web Application Specification) is a Rails-like framework for React, Node.js, and Prisma. Prior to version 0.16.6, Wasp authentication has a vulnerability in the OAuth authentication implementation (affecting only Keycloak with a specific config). Wasp currently lowercases OAuth user IDs before storing / fetching them. This behavior violates OAuth and OpenID Connect specifications and can result in user impersonation, account collisions, and privilege escalation. In practice, out of the OAuth providers that Wasp auth supports, only Keycloak is affected. Keycloak uses a lowercase UUID by default, but users can configure it to be case sensitive, making it affected. Google, GitHub, and Discord use numerical IDs, making them not affected. Users should update their Wasp version to `0.16.6` which has a fix for the problematic behavior. Users using Keycloak can work around the issue by not using a case sensitive user ID in their realm configuration.