Skip to main content
CVE-2025-49828VulnerabilityPublished Updated

CVE-2025-49828: cyberark conjur · Improper Neutralization of Special Elements Used in a Template Engine

Affects cyberark conjurSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 1.21.2 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.21.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade cyberark/conjur to 1.21.2.

Affected software

ProductAffectedFixed in
GitHubcyberark/conjurpkg:github/cyberark/conjurOther threatsAffected
  • <1.21.2
Fixed in
  • 1.21.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their deployment of CyberArk Conjur OSS and Secrets Manager Self-Hosted versions to identify if they are running affected versions. The primary mitigation is to upgrade to Conjur OSS version 1.21.2 or later, or Secrets Manager Self-Hosted version 13.5 or later, where the vulnerability is patched. Until patches can be applied, organizations should restrict access to the Secrets Manager API endpoints to trusted and authenticated users only, employing network segmentation and firewall rules to limit exposure. Implement strict authentication and authorization controls, including multi-factor authentication (MFA) for all users with access to the Secrets Manager. Monitor logs and audit trails for suspicious activity related to secret injection or template modifications. Conduct regular security reviews of secrets injection processes and ensure that templates are validated and sanitized before use. Additionally, consider implementing runtime application self-protection (RASP) or endpoint detection and response (EDR) solutions to detect anomalous behavior indicative of exploitation attempts. Finally, educate DevOps and security teams about this vulnerability to ensure rapid response and remediation.

Description

Conjur provides secrets management and application identity for infrastructure. Conjur OSS versions 1.19.5 through 1.21.1 and Secrets Manager, Self-Hosted (formerly known as Conjur Enterprise) 13.1 through 13.4.1 are vulnerable to remote code execution An authenticated attacker who can inject secrets or templates into the Secrets Manager, Self-Hosted database could take advantage of an exposed API endpoint to execute arbitrary Ruby code within the Secrets Manager process. This issue affects both Secrets Manager, Self-Hosted (formerly Conjur Enterprise) and Conjur OSS. Conjur OSS version 1.21.2 and Secrets Manager, Self-Hosted version 13.5 fix the issue.

References

Community reviews

Loading reviews…