CVE-2025-50200: rabbitmq-server · Sensitive Data in Logs
Affects rabbitmq-serverSource CVE Database V5
Not known to be exploited · CVSS 6.7 Medium · fixed in 4.0.8 : update rabbitmq-server when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 19 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubrabbitmq/rabbitmq-serverpkg:github/rabbitmq/rabbitmq-serverOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade RabbitMQ to version 4.0.8 or later, where this logging behavior has been corrected. Until upgrading, restrict access to RabbitMQ logs to trusted personnel only to prevent credential leakage. No other vendor advisory mitigation instructions are provided.
Description
RabbitMQ versions 3.13.7 and earlier log HTTP authorization headers in plaintext base64 encoding, exposing encoded username and password in logs. This vulnerability allows sensitive credential information to be easily decoded from logs. The issue has been fixed in RabbitMQ version 4.0.8.