Skip to main content
CVE-2025-50505VulnerabilityPublished Updated

CVE-2025-50505: n/a

Source CVE Database V5

0

Not known to be exploited · CVSS 7.8 High · fixed in 2.3.0 : patch affected systems soon.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

AI-suggested

1. Upgrade Clash Verge to version 2.3.0 or later, where the vulnerability is fixed. 2. If immediate upgrade is not possible, restrict local access to systems running vulnerable versions to trusted users only. 3. Use host-based firewalls or access control mechanisms to block or limit access to the clash-verge-service HTTP API endpoint locally. 4. Monitor system logs for unusual invocations of the `/start_clash` API or unexpected execution of binaries. 5. Employ application whitelisting to prevent unauthorized binaries from executing with elevated privileges. 6. Conduct regular audits of installed services and their exposed interfaces to detect unauthorized or insecure configurations. 7. Educate users about the risks of local privilege escalation and enforce the principle of least privilege to minimize potential damage from compromised accounts.

Description

Clash Verge Rev thru 2.2.3 (fixed in 2.3.0) forces the installation of system services(clash-verge-service) by default and exposes key functions through the unauthorized HTTP API `/start_clash`, allowing local users to submit arbitrary bin_path parameters and pass them directly to the service process for execution, resulting in local privilege escalation.

References

Community reviews

Loading reviews…