CVE-2025-5061: WP Import Export Lite · Unrestricted File Upload
Affects WP Import Export LiteSource CVE Database V5
Not known to be exploited · CVSS 7.5 High · fixed in 3.9.29 : patch WP Import Export Lite soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.9.29
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vjinfotech WP Import Export Lite | Affected
| Fixed in– |
AI-suggested
A partial patch was introduced in version 3.9.29; however, no complete official fix or patch link is currently available. Users should verify if a newer version beyond 3.9.29 fully addresses the vulnerability by consulting the vendor's advisory or update channels. Until a full fix is confirmed, restrict upload permissions strictly and monitor for suspicious file uploads.
Description
The WP Import Export Lite plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'wpie_parse_upload_data' function in all versions up to, and including, 3.9.29. This makes it possible for authenticated attackers, with Subscriber-level access and above, and permissions granted by an Administrator, to upload arbitrary files on the affected site's server which may make remote code execution possible. The vulnerability was partially patched in version 3.9.29.
References
- wordfence.com/threat-intel/vulnerabilities/id/5c0f3248-fef6-48a5-b2e1-f2778528fba1?source=cve (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-import-export-lite/trunk/includes/classes/import/class-wpie-upload-validate.php (opens in a new tab)
- plugins.trac.wordpress.org/browser/wp-import-export-lite/trunk/includes/classes/import/class-wpie-upload-validate.php (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3323402/ (opens in a new tab)
- plugins.trac.wordpress.org/changeset/3338701/ (opens in a new tab)