Skip to main content
VulnerabilityPublished

CVE-2025-52870: QNAP Systems Qsync Central · Buffer Overflow

Affects QNAP Systems Qsync CentralSource CVE Database V5

0

Not known to be exploited · CVSS 0.6 Low : upgrade to 5.0.0.4 ( 2026/01/20 ) when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
0.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.0.4 ( 2026/01/20 )
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade QNAP Systems Qsync Central to 5.0.0.4 ( 2026/01/20 ).

Affected software

ProductAffectedFixed in
QNAP Systems Inc.Qsync CentralAffected
  • =5.0.x.x
Fixed in
  • 5.0.0.4 ( 2026/01/20 )

AI-suggested

European organizations should immediately upgrade Qsync Central to version 5.0.0.4 or later to remediate this vulnerability. Additionally, organizations should audit user accounts to ensure only authorized users have access, minimizing the risk of exploitation. Network segmentation and restricting access to Qsync Central interfaces to trusted networks can reduce exposure. Monitoring logs for unusual crashes or memory errors related to Qsync Central may help detect attempted exploitation. Employing application whitelisting and runtime protections on QNAP devices can further mitigate risks. Regular vulnerability scanning and patch management processes should be enforced to promptly address similar vulnerabilities. Finally, educating users about credential security and enforcing strong authentication policies will reduce the likelihood of attackers gaining user accounts necessary for exploitation.

Description

CVE-2025-52870 is a buffer overflow vulnerability in QNAP Systems Inc. 's Qsync Central product affecting version 5.0.x.x. A remote attacker with a valid user account can exploit this flaw to modify memory or crash processes, potentially leading to denial of service or other unintended behavior. The vulnerability requires low privileges (a user account) but no user interaction and has a low CVSS score of 0.6. QNAP has released a fix in version 5.0.

References

Community reviews

Loading reviews…