CVE-2025-52897: glpi · Basic XSS
Affects glpiSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium · fixed in 10.0.19 : update glpi when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.0.19
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
AI-suggested
European organizations using GLPI should immediately upgrade to version 10.0.19 or later to remediate this vulnerability. Until the upgrade is applied, organizations should implement strict input validation and output encoding on the planning feature to neutralize script tags and prevent XSS payloads. Additionally, deploying Web Application Firewalls (WAFs) with rules to detect and block suspicious script injections or phishing URLs targeting GLPI can reduce risk. User awareness training focused on recognizing phishing attempts, especially those involving internal IT tools, is critical. Organizations should also monitor logs for unusual access patterns or phishing link distributions related to GLPI. Network segmentation can limit the impact if a compromise occurs. Finally, applying Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting the execution of unauthorized scripts in browsers.
Description
GLPI is a Free Asset and IT Management Software package. In versions 9.1.0 through 10.0.18, an unauthenticated user can send a malicious link to attempt a phishing attack from the planning feature. This is fixed in version 10.0.19.