CVE-2025-5302: run-llama/llama_index · Uncontrolled Recursion
Affects run-llama/llama_indexSource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 0.12.38 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.12.38
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade run-llama/llama_index to 0.12.38.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| run-llama run-llama/llama_index | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade the run-llama/llama_index library to version 0.12.38 or later, where the uncontrolled recursion issue is fixed. If immediate upgrade is not feasible, implement input validation and limit the depth of JSON nesting before parsing to prevent triggering the recursion limit. Employ runtime monitoring to detect abnormal resource consumption or Python process crashes related to JSON parsing. Additionally, consider sandboxing or isolating the JSON parsing component to contain potential crashes and prevent cascading failures. Network-level protections such as rate limiting and filtering of suspicious JSON payloads can reduce exposure to exploit attempts. Finally, maintain an inventory of systems using this library to ensure comprehensive patching and risk management.
Description
A denial of service vulnerability exists in the JSONReader component of the run-llama/llama_index repository, specifically in version v0.12.37. The vulnerability is caused by uncontrolled recursion when parsing deeply nested JSON files, which can lead to Python hitting its maximum recursion depth limit. This results in high resource consumption and potential crashes of the Python process. The issue is resolved in version 0.12.38.