Skip to main content
VulnerabilityPublished Updated

CVE-2025-53101: ImageMagick · Buffer Underrun

Affects ImageMagickSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.4 High : upgrade to 7.1.2-0 or 6.9.13-26 soon.

Data as of 29 Oct 2026, 23:48 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.4
Patch
Available – fixed in 7.1.2-0, 6.9.13-26
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade ImageMagick to 7.1.2-0 or 6.9.13-26.

Affected software

ProductAffectedFixed in
ImageMagick ImageMagickAffected
  • <7.1.2-0
  • <6.9.13-26
Fixed in
  • 7.1.2-0
  • 6.9.13-26

AI-suggested

Upgrade ImageMagick to version 7.1.2-0 or later, or 6.9.13-26 or later, where this vulnerability is fixed. No other mitigation is required as the issue is resolved in these official releases.

Description

CVE-2025-53101 is a high-severity buffer underrun vulnerability in ImageMagick's magick mogrify command. It occurs when multiple consecutive %d format specifiers are used in a filename template, causing pointer arithmetic to reference memory below the stack buffer start, leading to a stack overflow via vsnprintf(). This flaw affects versions prior to 7.1.2-0 and 6.9.13-26. The issue is fixed in these versions.

References

Community reviews

Loading reviews…