CVE-2025-55154: ImageMagick · Integer Overflow or Wraparound
Affects ImageMagickSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 7.1.2-1 or 6.9.13-27 soon.
Data as of 29 Oct 2026, 23:50 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 7.1.2-1, 6.9.13-27
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ImageMagick to 7.1.2-1 or 6.9.13-27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ImageMagick ImageMagick | Affected
| Fixed in
|
AI-suggested
Users should upgrade ImageMagick to version 6.9.13-27 or 7.1.2-1 or later, where this vulnerability has been fixed. Applying these official patches fully mitigates the risk. No additional mitigations are specified or required beyond updating to the fixed versions.
Description
CVE-2025-55154 is a high-severity integer overflow vulnerability in ImageMagick affecting versions prior to 6.9.13-27 and 7.1.2-1. The flaw occurs in the magnified size calculations within the ReadOneMNGImage function in coders/png.c, which can overflow and lead to memory corruption. This vulnerability has been patched in versions 6.9.13-27 and 7.1.2-1.